Typoscript: Config.

Standardeinträge für config {}

Folgende Einträge habe ich immer in meiner Template-Config:

config { 
     #Adminpanel aktivieren
    admPanel = 1  

    #Während der Entwicklung den Zwischenspeicher deaktivieren. ACHTUNG: Bei Livebetrieb abschalten. 
    no_cache = 1 
    doctype = xhtml_trans 
    
    #Spracheinstellungen 
    htmlTag_langKey = de-DE 
    language = de 
    locale_all = de_DE.UTF8 

    #SPAM-Protection dür die E-Mailadessen. Siehe unten das passende CSS 
    spamProtectEmailAddresses = 2 
    spamProtectEmailAddresses_atSubst = <span class=„nospam“></span> 
    spamProtectEmailAddresses_lastDotSubst = <span class=„punkt“></span> 

    #RealURL aktivieren 
     tx_realurl_enable = 1 
     baseURL = www.webadresse.de 
     redirectOldLinksToNew = 0 

     #ggf. Indexedsearch aktivieren 
     index_enable = 0 
     index_externals = 0 

     #Deaktiviert die Fehlermeldung, wenn FE-Render fehlschlägt („Oops an error occurred. Code: ...“) ACHTUNG: Nun im Produktiv-Modus 
     contentObjectExceptionHandler = 0 

     #Performance-Einstellungen (siehe auch hier) 
     removeDefaultJS = external 
     inlineStyle2TempFile = 1 
     disablePrefixComment = 1 
     compressJs = 1 
     concatenateJs = 1 
     compressCss = 1 
     concatenateCss = 1 
}

Und nun mein kleiner ANTISPAM-Trick. Ich finde es immer unglaublichunschön., wenn eine E-Mailadresse ein (AT) enthält. Ebenso ist es schwierig, ein Bild so einzubinden, dass es wie Text aussieht. Ich habe anfangs mehrere unsichtbare <span>-Elemente um die einzelnen Teile der E-Mailadresse geklebt. Ich denke, dass das aller Wahrscheinlichkeit nach ausreicht, um Bots zu irritieren. Dennoch würde ein intelligenter Bot alles finden, was er braucht. Anders bei meiner CSS-Variante. Hier lagere ich die Signalzeichen @ und . in unsere CSS-Datei aus. Die wird von Bots nicht interpretiert:

 

a span.nospam:after { content:'@' }
a span.punkt:after { content:'.' }